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Perry Rivera

I motivate and connect teams
with technology solutions and
provide customer-focused
training and support services
with System Administrator
experience in commercial,
educational and non-profit
industries.
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Overview
•What is Krita?
•History
•Installation Tips
•Basic Concepts of Krita
•Demo



4/99 Be Free. KDE

Scope
•Introductory Level
•Topics of Interest
for Various Levels

•Engineer with
VERY Basic Art Skills
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Pronunciation
•Heard various methods of this
•KREE-tah*

•KWEE-tah
•KRIH-tah

*See https://forum.kde.org/viewtopic.php?f=137&t=125338
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What is Krita?
•Digital Painting Program
•Use it For:
•Painting
•Sketching and Drawing
•Photo Retouching
•Comic Strips
•Pixel Art
•Web Banners
•Animation
•And More!
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A Brief History of Krita...
• 1998

• Matthias Ettrich's patch to GIMP
• KDE spun that off as KOffice's KImage

• 1999
• That spun off with two different names

• 2002: Renamed to Krita, to avoid potential
trademark infringements

• 2003: Development ramps up
• 2004-2009:

• Original goal is to make an Adobe®
Photoshop®/GIMPlike product

• 2009: New goal: Make a painting program
• 2013: Krita Foundation created
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Krita vs. Adobe® Photoshop®
Krita Adobe® Photoshop® 

Open Source Cloud Subscription
$$$

Digital Painting Image Editing
Brush Engines Brushes

Color to Alpha Filter Color Range or
The Works Plugin

~70 Blend Modes ~30 Blend Modes
Drawing Assistants ?

Multibrushes ?
Layer Styles Layer Effects
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Krita vs. GIMP
Krita GIMP

Open Source Open Source
Drawing,
Painting,

Photo Editing

Photo Editing

Text Tool Quirky Text Tool Quirky
Brushes Identifiable/Previewable

When You Mouseover Them
Brushes Identifiable When

You Select Them
Brushes Have Useful Names

Like "Textured Fuzzy"
Brushes Have Unhelpful

Names Like "Ripped Hole"
Pop-up Palette Not implemented
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Which Should You Use?
• Try them all!
• Use the tool/tools that best works/work

for you.
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Installation Basics

•Use Fedora Design Suite Spin
https://labs.fedoraproject.org/en/design-suite/
• Need to "dnf install calligra" to add

Calligra Suite.
• Can also "dnf install calligra-krita" to

add just Krita
•Use Chakra Distribution

• Krita is built-in. The distro is a little
tricky to setup...
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Installation Basics

• Install Using Your Distro's Default
Installation Processes...

•Latest and Greatest - Building
From Scratch
http://www.davidrevoy.com/article193/
guide-building-krita-on-linux-for-cats
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Installation Platform Hints

• For Mac
Try turning OpenGL support off:
community.cgcookie.com/t/mac-and-krita-is-
anyone-using-krita-on-the-mac-as-i-have-
questions/2170

• For PC
Install As You Normally Do...

• For Linux
Try testing with different workspaces,
including KDE
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Fedora Walkthrough
• Install Fedora Design Spin (Bare Metal or VM)
• As root-privileged user, install:

# dnf update
• As root-privileged user, install:

# dnf install calligra-krita
   OR
# dnf install calligra

• As root-privileged user:
# dnf install switchdesk
# dnf install @kde
# switchdesk kde

• As regular user, invoke:
• $ krita
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User Interface

https://userbase.kde.org/Krita/Manual/Interface
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Pop Up Palette
• Right Click
• Settings -> Select Favorite Presets
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View Canvas Only
• Tab Key
• View -> Show Canvas Only
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Zoom
• Zoom Out: Ctrl Minus or Mouse Scroll

Reverse
• Zoom In: Ctrl Plus or Mouse Scroll

Forward
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Menus (Top of Screen)
• Image Menu

• Affects Entire Image
• Layer Menu

• Affects Individual Layers
• Use this for Making Collages

• Select Menu
• Affects Selections

• Filter Menu
• Applies Filters to Selections/Canvas.

• Tools Menu
• Macros!

• Settings Menu
• Configure Shortcuts: Keyboard Shortcuts
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Krita Tools (Left Side)
Vector Tools

Drawing Tools

{
{
{
{
{

Manipulation Tools: Crop, Move, Transform, Measure
• Affects Entire Image

        
Color Tools: Fill, Eyedropper, Gradient
Assistant Tools: Rulers, Grids

 
Selection Tools
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Introductory Terms
• Brush Presets
• Right side, second tab.
• Play and Experiment...many choices!
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Introductory Terms

•Brush Size
•Smaller Brush: [ Key
•Larger Brush:   ] Key
or

•Shift and Drag Left Mouse
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Introductory Terms
• Symmetry Mode

• Press the buttons to create axes for
reflection...

• Choose a brush, size, and paint
• Make Snowflakes, Jewelry, and More
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Introductory Terms
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Color Themes
• Settings Menu -> Theme -> 

(pick one)
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Toolbars
• Settings Menu -> Configure Toolbars
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Dockers
• Settings Menu -> Dockers -> ...

• Turns on the Various Tools at Your
Disposal...

• Palette
• Overview
• More!

• Save Your Workspace
• Choose Create Workspace Icon:
• Type in a New Name



28/99 Be Free. KDE

Wrap-Around Mode
• "W" Key

• Creates a Repeating Texture
• Use the "M" Key and Paint to Continue

Repeating...
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Wrap-Around Mode
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Pan Canvas

•Press Wheel Button Down or
SPACE+mousing
•Repositions the Canvas
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Rotate Canvas

•Press CTRL [ or CTRL ]
•4 - ROTATE LEFT
•5 - ROTATE RESET
•6 - ROTATE RIGHT
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Lighten/darKen Color

•Lighten: L
•DarKen: K
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Export

•File Menu > Export
Choose a filename and a filetype

•File Menu > Export as PDF...
Click OK, then choose a filename
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Layers
• Think of Clear Sheets of Plastic Atop a

Background
• Bottom Layer is the Background

• Transparent (for Web Banners, etc.)
• Opaque

• Can Group These
• e.g. Face Layer Group Could Have Eyes,

Nose, Hair, and so on..
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Layers
• Visibility
• Layer Lock
• Alpha Lock
• Alpha Inheritance

• Add
• Duplicate
• Move Layer Down
• Move Layer Up

Move Outside of Group
• Move Inside of Group
• Layer Properties
• DeleteLayer
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Layers

•Add Layer
•  Insert key - Inserts Paint Layer

•Remove Layer
•Click on desired layer to remove..
•Right-click on layer,

choose Remove Layer
•Duplicate Layer

•  CTRL J
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Case Study: Sunny Day
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Layers

•Layers Add Extra Complexity
•Save First!
•Flatten Layers If You No Longer

Need the Sublayers.
•Right Click the Layer and Choose:

•Flatten Image
or

•Flatten Layer
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Layers

•Knowledge Check:
• How Would You Create the Following

Three Layers?
• TOP: Ink
• MIDDLE: Sketch
• BOTTOM: Canvas
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Undo and Redo

•Undo: CTRL Z
•Redo: CTRL SHIFT Z
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Erase Mode

•Hit E
•Any brush or drawing tool can be
turned into an eraser...
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Mirror Image Mode

•Hit M
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Stabilizer Mode

•Might be Useful if You Use a
Mouse While Painting...

•Docker: Tool Options
•Change Dropdown
Smoothing from Basic
Smoothing to Stabilizer
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Foreground/Background Color

Foreground
Color.
Click to Choose
a Different One..

Background
Color.
Click to Choose
a Different One...

Click Here or Hit X on
Your Keyboard to Swap
These Two Colors

Click Here or hit D
on Your Keyboard to
Reset Foreground Color to
Black and Background
Color to White
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Fill a Layer with Color

•Backspace: 
Fill with BACKground Color

•Shift+Backspace:
Fill with FOREground Color

•Great for Masked Photos!
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Color History

•See/Select Your History in the Color
Selector

•History is Visible in the Pop-up
as well
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Brush Engines (Up Top)
• Brush Settings, Brush Presets

• Pencil
• Sketch
• Airbrushes
• Bristle Brushes
• Brush Tip

• Auto, Predefined, Text
• Use "Shift" and Drag Mouse to Change Size of the

Brush...
• Click on the Tool Options tab to play around with the

various settings...



48/99 Be Free. KDE

Toolbar (Top)

• Gradient
• Fill Pattern
• Brush Engine
• Brush Settings
• Blending Modes
• Eraser
• Preserve Alpha
• Reload Original Preset
• Opacity/Size/Flow
• Mirror: Set Horizontal/Vertical
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Scaling

•Image Menu: Scale to New Size
•Change to larger or smaller size
accordingly...
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Blending Modes
• Algorithms describing how colors are mixed

together
• http://heap.kogmbh.net/downloads/Introductio

ntoKritaforusercomingfromPs.pdf
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Blending Modes
• Create a new Filter (NOT Filter Mask!) Layer

• Type a name for that new Filter Layer
• Click OK

• Change Blend Mode from Normal to X
• Popular Ones Include:

• Normal (The Default)
• Multiply (Darken)
• Screen (Lighten)
• Overlay
• Soft Light
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Blending Modes (cont'd)

• Color Blending Mode: For grisailles
greyscale underpainting (colorizing
greyscale pictures) or general colorizing.
• Duplicate Paint Layer (Ctrl+J)
• Set Layer Blending Mode to Color
• Paint Grey (Desaturation) or Paint With

Another Color
• Reduce the Opacity to a Reasonable

Level.
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Blending Modes (cont'd)
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Shapes
• Squares
• Circles
• Polygons
• Polylines-Similar to Polygons, but not

connected at the end
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Transform
• "T" and Ctrl+T

• Hold SHIFT to maintain aspect ratio
• Perspective Skew

• Hit Ctrl and Drag a Handle
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Perspective Transform
• Ctrl+T
• Tool Options Docker

• Choose Perspective (second tool)
• Drag Handles of Object



57/99 Be Free. KDE

Filter Menu
• Use Create Filter Mask on Layer for Flexibility

• Gaussian Blur: Smooth Blurring of Image

• G'MIC: GREYC's Magic for Image Computing
• Patterns

• Experiment!
• Frames

• Check out:
• Frames > Polaroid
• Frames > Frame [Fuzzy]

• Countless More
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Some G'MIC Examples

Frames > Polaroid
Frames > Fuzzy
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Text Tool
• Adds a Vector Layer for Text

• Vector:
• Paths defined by math formulas
• When scaled up, image will not be

pixellated/distorted [unlike rasters]
• Note that you can interleave Vector Layers

with Raster Layers
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Favorite Presets

• Go to Brush Presets Docker
• Right Click on a Desired Brush Preset

• Right-Click and Choose
Assign to Tag

• Choose: Favorite Preset or any other
group

• Right click on the canvas and see that
your preset is added
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Case Study: Jewelry/Snowflake

• Symmetry Mode
• Choose a Brush
• Choose a Color
• Choose a Size
• Draw!
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Case Study : Jewelry/Snowflake

• Multibrush Tool
• Choose a Brush Preset
• Choose a Brush Color
• Choose a Brush Size
• Draw!
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Case Study : Jewelry/Snowflake

• Tool Options Docker
• Drag number slider at the bottom to

choose Brush Count
• Draw!
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Case Study: Frown to Smile
• Use the Transform Tool (Ctrl+T)
• Shift+Mouse Button to Change Brush Size
• Docker: Tool Options > Liquify 

• Mode: Build Up
• Size: Choose a Good Size (Experiment!)
• Tweak Cheek Up - Avoid the Joker Effect

• Docker: Tool Options > Warp
• Anchor Points: Draw
• Create Points
• Lock Points
• Drag Points
• Hit Enter
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Case Study: Frown to Smile

BEFORE AFTER
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Case Study: Penguin Looks Up
• Works Well With Lone Sketches on a Blank or

Transparent Background
• Use the Transform Tool (Ctrl+T)
• Docker: Tool Options > Cage 

• Draw Cage Around Object
• Close the Cage
• Tweak the Cage for Desired Effect
• Use Clone to Clean Up Where Necessary...
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Case Study: Penguin Looks Up

BEFORE CAGE STRATEGY
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Case Study: Penguin Looks Up

BEFORE AFTER
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Case Study: Collage / Visionboard
• File->New

• Custom Size
• Fill in appropriate Dimensions
• Click Create Button

• Layer Menu->Import/Export->Import
• as Paint Layer...
• Choose Each Picture One by One

• Layer Tab
• Highlight Layer
• Ctrl+T
• Shift Click and Drag the Picture's Corner Handles
• Move the Layer to an Ideal Location

• Rotation
• Optionally Move Rotation Axis
• Drag Outside of the Picture to Rotate the Picture
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Case Study: Collage / Visionboard
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Case Study: Collage / Visionboard
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Case Study: Blemish/Debris Removal

• Toolbar->Edit brush settings
• Click on Clone Brush Engine (on the left

hand side)
• Hold down the Ctrl Key and Click on an

Ideal Source (Clean Surface with No
Defects Visible)

• Release the Ctrl Key
•
• Click on the blemish to remove...
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Case Study: Transparency Mask 1 of 2

• Select Oval Selection Tool
(Lower Left Corner)

• Select a Portion of Your Photo

• Select > Feather Selection...
Type 10 or 15 (pixels) and click OK

• Choose Dropdown next to New Layer              > 
Transparency Mask

• New Layer (Insert Key)
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Case Study: Transparency Mask 2 of 2

• Select Menu > Deselect
• Press Shift+Backspace to fill with

FOREground color
• Move This Layer to the Bottom
• Optionally Rename This Layer to

Background
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Case Study
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Case Study
• Layer Styles

• Layer Menu > Layer Styles...
• Use the Fx button to view your applied

style...



77/99 Be Free. KDE

What's Missing

• Snap to Grid
• Snap to Ruler
• Guidelines
• Nudging Layers (Scheduled for v3.0)
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How Can You Help?

• Learn and Use It
• Teach It
• Develop for It

• https://krita.org/get-involved/overview/
• Tell Others About It
• Fund Krita Development

https://krita.org/support-us/donations/
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Conclusion

Use Krita to:
•Paint
•Edit/Retouch Photos
•Make Web Banners
•More!
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Questions

??????????????????????????????????
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Survey

Online Evaluation for This Presentation:
http://goo.gl/forms/ndlR6RT1YP
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Perry Rivera

Please feel free to stop by the
Fedora table and say hello!
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Thank You!

Thank You for Attending!
Perry Rivera

Twitter: @pvrconsulting
E-mail: perry-rivera@alumni.calpoly.edu
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Bonus Slides!

Here’s Some Fun Stuff...
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Keyboard Shortcuts

• https://colorathis.wordpress.com/2014/02/2
0/krita-2-8-shortcuts-cheatsheet/
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David Revoy Brushes
• Optional, but useful!

• Download Bundle from:
http://www.davidrevoy.com/article264/brushkit-v7-0

• Settings Menu > Manage Resources... >
Import Bundle
• Choose Resource Bundle Under File Type.
• Change Filter to Resource Bundle
• Double Click on deevad.bundle

• May need to restart Krita
• New brushes show up in Brush Presets
• Change the Brush Presets dropdown to deevad
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Case Study: Aging Document
•Click Similar Color Selection
Tool

•Click on Color in Picture That
You'd Like to Re-COLOR

•Cut Selection to New Layer:
Ctrl+Shift+J

•Choose a Color from the Color
Picker

•Choose the Fill Tool
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Case Study: Aging Document
• Click on the any spot with the former color...
• Move that Layer to the bottom of the stack.
• Rename This Layer to Background.
• Click on Text Layer
• Change Text Layer Blend Mode to Multiply
• Duplicate Layer
• Change Mode to Multiply
• Click Select > Deselect
• Text Layer: Hit Ctrl+J to Duplicate, which darkens further...
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Case Study: Aging Document

BEFORE AFTER
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Other Resources
• Introduction to Krita for Adobe®

Photoshop® Users

http://heap.kogmbh.net/downloads/Introducti
ontoKritaforusercomingfromPs.pdf

• Brushes
https://krita.org/learn/resources/
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Other Resources
• Why I'm Switching From GIMP to Krita

http://www.linux-magazine.com/Online/Blogs/Off-
the-Beat-Bruce-Byfield-s-Blog/Why-I-m-
switching-from-GIMP-to-Krita

• David Revoy Brushes
www.davidrevoy.com/article264/brushkit-v7-0

• Muses DVD
https://krita.org/item/muses/

• Muses Brushes
https://krita.org/item/the-muses-preset-pack/
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Other Resources
• Blend Modes

Painting Assistants
Multibrushes

http://www.linux-magazine.com/Online/Blogs/Off-the-
Beat-Bruce-Byfield-s-Blog/Why-I-m-switching-from-
GIMP-to-Krita

• Krita Manual - Differences
https://userbase.kde.org/Krita/Manual/Differences

• Alpha Inheritance and Layer Management
https://userbase.kde.org/Krita/Tutorial_2#Layer_mana
gement
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Installation Hints: Fedora
• For Linux - Living on the Edge!

• If you like Alpha releases, try this:
https://krita.org/item/first-krita-3-0-pre-alpha/

• Save this file: http://files.kde.org/krita/3/linux/krita3-
prealpha-f7f43f2-x86_64.appimage

• Install/Enable:
• Fuse
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Appendix Slides

Fine Print and Other Stuff...
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Photo Citations
• Manuscripts and Archives Division, The New York Public

Library. "Letter to --" The New York Public Library Digital
Collections. 1824.
http://digitalcollections.nypl.org/items/b917eb3b-defd-ad32-
e040-e00a18060e3e

• Science, Industry and Business Library: General Collection
, The New York Public Library. "Unidentified man." The
New York Public Library Digital Collections.
http://digitalcollections.nypl.org/items/510d47de-03c8-
a3d9-e040-e00a18064a99

• Rare Book Division, The New York Public Library. "Dessert
held by Le Cirque at Le Cirque (RESTAURANT)" The New
York Public Library Digital Collections. Undated.
http://digitalcollections.nypl.org/items/a4958095-4675-074d
-e040-e00a1806792c

• Manuscripts and Archives Division, The New York Public
Library. "Florida Participation - Troubadour with guitar" The
New York Public Library Digital Collections. 1935 - 1945.
http://digitalcollections.nypl.org/items/5e66b3e8-af78-d471-
e040-e00a180654d7
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Photo Citations
• George Arents Collection, The New York Public Library.

"King penguin (Aptenodytes pennanti)." The New York
Public Library Digital Collections.
http://digitalcollections.nypl.org/items/510d47e3-20bb-a3d9-
e040-e00a18064a99

• The Miriam and Ira D. Wallach Division of Art, Prints and
Photographs: Photography Collection, The New York Public
Library. "Wife of Mr. Thaxton, farmer, near Mechanicsburg,
Ohio" The New York Public Library Digital Collections. 1938.
http://digitalcollections.nypl.org/items/aa898c30-089d-0133-
6647-58d385a7b928

• Rare Book Division, The New York Public Library. "Beautiful
Cat, Felis ornata." The New York Public Library Digital
Collections. 1830 - 1834.
http://digitalcollections.nypl.org/items/510d47da-9eda-a3d9-
e040-e00a18064a99

• Billy Rose Theatre Division, The New York Public Library.
"Monte Blue" The New York Public Library Digital
Collections. 1937.
http://digitalcollections.nypl.org/items/510d47d9-f3d0-a3d9-
e040-e00a18064a99
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Photo Citations
• General Research Division, The New York Public Library.

"Great Awk; Patagonian Penguin." The New York Public
Library Digital Collections. 1809.
http://digitalcollections.nypl.org/items/510d47d9-5172-a3d9-
e040-e00a18064a99
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Legal Stuff
• The Stichting Krita Foundation owns the Krita

trademark.
• All other trademarks are the property of their

respective owners.
• There is no warranty for this software. It is always

a great idea to Save your work!
• From GNU Public License v3:

• THERE IS NO WARRANTY FOR THE PROGRAM, TO THE EXTENT
PERMITTED BY APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED
IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES
PROVIDE THE PROGRAM “AS IS” WITHOUT WARRANTY OF ANY KIND,
EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO,
THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
PARTICULAR PURPOSE. THE ENTIRE RISK AS TO THE QUALITY AND
PERFORMANCE OF THE PROGRAM IS WITH YOU. SHOULD THE
PROGRAM PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL
NECESSARY SERVICING, REPAIR OR CORRECTION.
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Thank You!

Thank You for Attending!
Perry Rivera

Twitter: @pvrconsulting
E-mail: perry-rivera@alumni.calpoly.edu


